Localized language http api request response

It looks like that, response message from kintone rest api localize language someway

when i tried to send a request the message that i received was English but my another colleague who works in another country (he’s working in Japan) received Japanese message even if we 've used a common kintone app and a shared account.

i tried to change some localize setting in kintone config but everything’s still consistent.

What i’m curious is that is there any way to change language of rest api response message as my desire

Thank you!

Hi, Nguyễn Hiệp

There is Localized on system-level.

I looked for the document, but I found only the Japanese version.

バイリンガルなkintone使いの人たちへ システムレベルでのローカライズ

I translated it by google.


And one more important role for system locale.
That is the behavior when hitting REST API with user authentication.

· Strike the REST API with user authentication
· The accept-language header is not specified
· The language setting of the user who authenticated user is set to “follow Web browser settings”
· I hit the API that returned an error

If all these four conditions are met, cybozu.com can not determine the language in which the error message should be returned. That is why the system locale is confirmed and the language of the error message is returned according to the language set for that language.
It is to prevent errors from being returned in Japanese to users who only understand English 9 (‘ω’) و

If you encounter a situation like “If you developed kintone for users communicating in English and all the errors have been returned in Japanese,” this system locale is in English Let’s confirm that.

thank you, i finally found language setting of user 's set to “Follow Web Browser Setting” and it affects to the language of rest api response 

thank you so much!